Photo albums are unavailable on web

Incident Report for Jottacloud Public

Resolved

This incident has been resolved.
Posted Dec 05, 2024 - 10:54 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 05, 2024 - 10:32 CET

Investigating

We are currently investigating this issue.
Posted Dec 05, 2024 - 10:18 CET
This incident affected: Websites.