Photos web is down

Incident Report for Jottacloud Public

Resolved

Latest release has been rolled back
Posted Mar 28, 2023 - 13:29 CEST

Investigating

Photos web is down
Posted Mar 28, 2023 - 13:20 CEST
This incident affected: Websites.