Video playback problems
Incident Report for Jottacloud Public
Resolved
Video playback is now working again
Posted Oct 12, 2021 - 09:07 CEST
Investigating
We are currently having problems with video playback
Posted Oct 12, 2021 - 09:01 CEST
This incident affected: Websites and Mobile application.