Our auth platform is experiencing problems
Incident Report for Jottacloud Public
Resolved
This incident has been resolved.
Posted Nov 08, 2020 - 23:13 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2020 - 22:04 CET
Investigating
We are currently investigating this issue.
Posted Nov 08, 2020 - 20:29 CET
This incident affected: Websites, Desktop application, Mobile application, and API.