Authentication service interruption
Incident Report for Jottacloud Public
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 09:05 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 04, 2022 - 08:53 CEST
This incident affected: Websites, Desktop application, Mobile application, and API.