Authentication platform instability
Incident Report for Jottacloud Public
Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 10:23 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2023 - 10:09 CEST
This incident affected: Websites.